Skip Navigation

Reducing Kubernetes patch versions supported in Azure Kubernetes Service

Posted on Monday, September 24, 2018

Starting this week, Azure Kubernetes Service (AKS) will start supporting only two stable patch versions for every minor version available.

Previously, AKS supported five Kubernetes minor versions: 1.7,1.8,1.9,1.10, and 1.11. Reducing support to two patches per minor version removes the complexity of having to choose between multiple patch versions. If you are on a patch version that is no longer supported, you won't be affected at all. You can choose to remain on that patch version or upgrade to one of the two supported patch versions in that minor version or the next minor version. 

Patch releases are only intended to fix critical bugs in the minor versions (including security vulnerabilities), along with major bugs that affect a large number of customers and products running in production based on Kubernetes. They do not include any new feature integrations. There is never any incompatibility between patch versions of a minor version. This change is currently rolled out across all global regions and should be complete by the end of the week. 

Related feedback