Pro aplikace Power BI Embedded se doporučuje TLS 1.2

Datum publikování: 10 dubna, 2019

Pro zajištění toto, aby zákazníci měli kontrolu nad zabezpečením komunikace se službami Microsoftu, v rámci programů Microsoftu důrazně doporučujeme (a v budoucnosti budeme vyžadovat), abyste verzi TLS vaší aplikace upgradovali na TLS 1.2. 

Co je TLS?

TLS je zkratka pro Transport Layer Security. Jde o standardní protokol, který je navržený pro ochranu informací přenášených po internetu. TLS se využívá v řadě webových prohlížečů a aplikací, které komunikují přes HTTPS a TCP.

Pokud používáte aplikace .NET, proveďte jednu z následujících akcí:

  • Pokud vaše aplikace běží na rozhraní .NET Framework 4.6 nebo novějším, výchozí konfigurace bude dál fungovat (pokud se nezměnila).
  • Pokud vaše aplikace běží na rozhraní .NET Framework starším než 4.6, můžete tento protokol povolit prostřednictvím kódu programu, když se vaše aplikace spustí, a to pomocí následujícího řádku kódu:

System.Net.ServicePointManager  .SecurityProtocol |= SecurityProtocolType.Tls11 | SecurityProtocolType.Tls12;

Power BI API SDK podporuje .NET Standard 2.0 od verze 2.1.0, která doplňuje podporu v TLS verze 1.2. Nejnovější verzi sady SDK si můžete stáhnout tady.

Powershell: Do vašeho powershellového skriptu přidejte [System.Net.ServicePointManager]::SecurityProtocol = [System.Net.SecurityProtocolType]::Tls12.

Jiný software než .NET: Situaci proberte s vaším dodavatelem. U většiny jazyků stačí jednoduchá konfigurační položka.

Další informace najdete v tématu věnovaném podpoře TLS 1.2 v Microsoftu.

  • Power BI Embedded
  • Security

Související produkty