Aktualizace zabezpečení modulu Moby ve službě Azure IoT Edge pro CVE-2020-13401

Datum publikování: 02 června, 2020

V komponentě modulu Moby ve službě Azure IoT Edge bylo zjištěno ohrožení zabezpečení. (Verzí pro Windows se to netýká.) Získejte podrobné informace o tomto problému: CVE-2020-13401.

Potíže v modulu Moby 3.0.12 nebo novějším opravte pomocí následujících kroků:

  1. Zastavte proces démon iotedge.
    • sudo systemctl stop iotedge
       
  2. Odeberte stávající balíček moby-engine.
    • sudo apt-get remove docker
       
  3. Odstraňte uložený kontext moby-engine. Tím se odeberou všechny kontejnery uložené v mezipaměti.
    • ​​sudo rm -rf /var/lib/docker
       
  4. Postupujte podle pokynů pro instalaci moby-engine a po dokončení instalace ověřte, že jde o verzi 3.0.12 nebo novější.
    •  sudo docker version
       
  5.  Spusťte proces démon iotedge.
    •  sudo systemctl start iotedge

Stáhněte si balíček RPM.

  • Azure IoT Edge
  • Compliance
  • Security

Související produkty