NOW AVAILABLE

Upgrade the TLS version of your Power BI application to TLS 1.2

Published date: March 10, 2020

Support for transport layer security (TLS) 1.0 and 1.1 for Power BI will end in June 2020. Upgrade the TLS version of your Power BI application to TLS 1.2 before then. 

What is TLS? 

Transport layer security (TLS) is a protocol that’s an industry-standard designed to protect the privacy of information communicated over the internet. TLS is used in many web browsers and applications that communicate over HTTPS and TCP. 

How to upgrade the TLS version if you're using the .NET application 

  • If your application is running on .NET Framework 4.6 or higher, the default configuration will continue to work unless modified.
  • If your application is running on .NET Framework older than 4.6, you can enable the protocol programmatically when your application starts to run using this line of code: 
    System.Net.ServicePointManager .SecurityProtocol |= SecurityProtocolType.Tls11 | SecurityProtocolType.Tls12; 

Power BI API SDK supports .NET standard 2.0 from version 2.1.0, which adds support in TLS version 1.2. Download the latest SDK version

How to upgrade the TLS version if you're using PowerShell

[System.Net.ServicePointManager]::SecurityProtocol = [System.Net.SecurityProtocolType]::Tls12  

For most other languages, it can be done with a simple config entry. Check with your vendor.

See more information.

  • Power BI Embedded
  • SDK and Tools
  • Security

Related Products