IN DER VORSCHAU

Azure Bot Service erzwingt TLS 1.2 (Transport Layer Security)

Veröffentlichungsdatum: 14 November, 2018

Ab dem 4. Dezember 2018 erzwingt Azure Bot Service für alle Verbindungen einen Schutz durch TLS 1.2 (Transport Layer Security).

Dies ist wichtig, um die bestmögliche Sicherheit für Ihre Daten zu gewährleisten. Microsoft, die Payment Card Industry (PCI) und die gesamte Internetcommunity stellen von TLS 1.0 und TLS 1.1 um, da sich beide Versionen in der Vergangenheit als Angriffsfläche gezeigt haben.

Diese Änderung wird für alle Verbindungen mit Azure Bot Service-Servern erzwungen – egal ob von einem Chatclient oder einem Bot. Sie wird aber noch nicht für Verbindungen vom Azure Bot Service zu Bots erzwungen.

 

Weitere Informationen

Bei den meisten Verbindungen mit Azure Bot Service wird bereits TLS 1.2 verwendet. Die wenigen anderen Verbindungen stammen von alten Clients oder Betriebssystemen. In den meisten Fällen muss für die Aktivierung von TLS 1.2 lediglich ein Upgrade auf einen neuen Browser oder ein Patch für das Betriebssystem ausgeführt werden.

Bots wird weiterhin die Annahme der alten Protokolle erlaubt, wir werden dies jedoch in Zukunft einstellen. Aus diesem Grund sollten Bot-Entwickler ihre Server für die Annahme von TLS 1.2 oder höher konfigurieren. Wenn Ihr Bot in Azure Web-Apps oder Functions gehostet wird, ist die Umstellung ganz einfach. Wenn Ihr Bot auf einer älteren Windows-Version wie Windows Server 2008 oder Windows 7 (Windows Server 2008 R2) gehostet wird, müssen Sie einen Patch installieren, um die aktualisierten Protokolle zu aktivieren. TLS 1.2 wird unter Windows Vista und älteren Versionen nicht unterstützt.

Bei den folgenden Clients kann TLS 1.2 nicht verwendet werden. Aktualisieren Sie Ihre Clients, und motivieren Sie Ihre Kunden, dasselbe zu tun, um einen unterbrechungsfreien Zugang zum Dienst zu gewährleisten.

  • Android bis Version 4.3
  • Firefox bis Version 5.0
  • Internet Explorer 8 bis 10 unter Windows 7 und früheren Versionen
  • Internet Explorer 10 unter Win Phone 8.0
  • Safari 6.0.4/OS X 10.8.4 und frühere Versionen

Weitere Informationen

  • Azure Bot Services
  • Compliance
  • Services

Verwandte Produkte