Navigáció kihagyása
MÁR ELÉRHETŐ

Azure IoT Edge 1.0.5-es kiadás

Közzététel dátuma: december 19, 2018
Az Azure IoT Edge 1.0.5-ös frissítése a következő fejlesztéseket tartalmazza:
 
Stabilitás minden operációs rendszerhez
Számos hibajavítás az Edge Hubon és az iotedged szolgáltatásban. (A változások teljes listáját a GitHub kibocsátási megjegyzéseiben találja.) Főbb változások:
  • Továbbfejlesztettük a hibaüzenetek információit.
  • Konfigurálhatóvá tettük az időtúllépési időszakot. Ez különösen hasznos lassú kapcsolattal rendelkező eszközök esetén, amelyeken a műveletek több időt vesznek igénybe, mint magas sávszélességű kapcsolatok használatakor. 
Edge a Windowson
Az 1.0.5 a Windows x64 IoT Edge (minimum RS5 verzió) környezetben lett kiadásra jelölve. Ez a verzió jelentősen csökkenti a Windowson és Linuxon futó modulok közti különbségeket. A Windows-modulok mostantól hasonló biztonsági funkciókat használhatnak, hatékonyabb, folyamataiban elkülönített tárolókkal futhatnak, valamint olyan hardverekhez férhetnek hozzá, mint a Serial, az SPI, a GPIO és a GPU-gyorsítás a WinML-lel. Az Edge Agent és az Edge Hub mostantól az RS5-öt használja vendég operációs rendszerként a tárolóban. Ez a következőkkel jár:
  • Az RS4 gazda operációs rendszert használó, IoT Edge 1.0.4-et futtató eszközök nem tapasztalnak változást.
  • Az RS4-ről RS5-re frissítő, IoT Edge 1.0.4-et futtató eszközök nem tapasztalnak változást.
  • Az új, RS5 gazda operációs rendszert használó eszközök megfelelően működnek az IoT Edge 1.0.5-tel.
  • Az RS4-eszközök nem futtathatók gazda operációs rendszerként az IoT Edge 1.0.5 esetén.
A Java- vagy Node-modulokat író felhasználóknak célszerű továbbra is az 1.0.4 verziót használniuk mindaddig, amíg a Java és Node SDK-k nem támogatják az IoT Edge 1.0.5-öt Windows RS5 rendszeren.
 
A Security Daemon a frissítést követően szimulált TPM helyett fizikai TPM-et használ a DPS üzembe helyezési folyamatában.
 
A Visual Studio és a VS Code eszközkészlete frissült az IoT Edge 1.0.5-tel való kompatibilitáshoz. Az 1.0.4 verziót továbbra is használni kívánó Windows-felhasználóknak követniük kell az ebben a blogbejegyzésben található utasításokat.
 
  • Features