Azure Kubernetes Service – A Kubernetes 1.11-es és 1.12-es verziók támogatását megszüntetjük

Közzétéve: 2019. szeptember 30., hétfő

2019. december 9-én, hétfőn megszüntetjük azoknak a Kubernetes-verzióknak a támogatását, melyek régebbiek a legújabb verziónál (N) és a két megelőző alverziónál (N-2), mert azon a napon általánosan elérhetővé válik a Kubernetes 1.15-ös verziójának támogatása. Azoknak az ügyfeleknek, akik a Kubernetes 1.13.x verziójánál régebbi verziót futtatnak, 2019. december 9-ig frissíteniük kell, hogy továbbra is támogatást kaphassanak. Azt követően felkérjük az ügyfeleket, hogy frissítsenek egy támogatott verzióra, amikor új Azure-támogatási kérelmet nyitnak meg. Felhívjuk figyelmét, hogy a dátum csak az AKS-re vonatkozik, és nem érvényes a Kubernetes 1.15 kiinduló vagy közösségi dátumaira.

Ezt a változtatást azért végezzük most el, hogy jobban követhessük a kiinduló Kubernetes-projektet, és hogy konzisztensebb felhasználói élményt biztosíthassunk az ügyfeleinknek a hibajavítások, a biztonsági javítások és az összetevők kompatibilitása terén.

Ennek a változásnak köszönhetően az AKS támogatni fogja a Kubernetes jelenlegi általánosan elérhető kiadását és a két korábbi alverzióját (N-2). Az AKS eddig is mindig a Kubernetes aktuális általánosan elérhető kiadását és a három megelőző alverzióját (N-3) támogatta. Ha megjelenik egy új alverzió, a legrégebbi alverziót eltávolítjuk.

2019. december 9. hétfő után a Kubernetes támogatott alverziói az alábbiak lesznek:

  • 1.13.x
  • 1.14.x
  • 1.15.x

Ha ellenőrizni szeretné, hogy az Ön régiójában mely verziók érhetőek el:

```
az aks get-upgrades --resource-group myResourceGroup --name myAKSCluster --output table
```

A fürtök frissítéséhez az Azure CLI használatával:

```
az aks upgrade --resource-group myResourceGroup --name myAKSCluster --kubernetes-version <ÚJ VERZIÓ>
```

További információt az AKS Kubernetes támogatási szabályzatában talál.

Ha kérdezni szeretne, írjon nekünk.

 

 

2019. december 9-én, hétfőn megszüntetjük azoknak a Kubernetes-verzióknak a támogatását, melyek régebbiek a legújabb verziónál (N) és a két megelőző alverziónál (N-2), mert azon a napon általánosan elérhetővé válik a Kubernetes 1.15-ös verziójának támogatása. Azoknak az ügyfeleknek, akik a Kubernetes 1.13.x verziójánál régebbi verziót futtatnak, 2019. december 9-ig frissíteniük kell, hogy továbbra is támogatást kaphassanak. Azt követően felkérjük az ügyfeleket, hogy frissítsenek egy támogatott verzióra, amikor új Azure-támogatási kérelmet nyitnak meg. Felhívjuk figyelmét, hogy a dátum csak az AKS-re vonatkozik, és nem érvényes a Kubernetes 1.15 kiinduló vagy közösségi dátumaira.

Ezt a változtatást azért végezzük most el, hogy jobban követhessük a kiinduló Kubernetes-projektet, és hogy konzisztensebb felhasználói élményt biztosíthassunk az ügyfeleinknek a hibajavítások, a biztonsági javítások és az összetevők kompatibilitása terén.

Ennek a változásnak köszönhetően az AKS támogatni fogja a Kubernetes jelenlegi általánosan elérhető kiadását és a két korábbi alverzióját (N-2). Az AKS eddig is mindig a Kubernetes aktuális általánosan elérhető kiadását és a három megelőző alverzióját (N-3) támogatta. Ha megjelenik egy új alverzió, a legrégebbi alverziót eltávolítjuk.

2019. december 9. hétfő után a Kubernetes támogatott alverziói az alábbiak lesznek:

  • 1.13.x
  • 1.14.x
  • 1.15.x

Ha ellenőrizni szeretné, hogy az Ön régiójában mely verziók érhetőek el:

```
az aks get-upgrades --resource-group myResourceGroup --name myAKSCluster --output table
```

A fürtök frissítéséhez az Azure CLI használatával:

```
az aks upgrade --resource-group myResourceGroup --name myAKSCluster --kubernetes-version <ÚJ VERZIÓ>
```

További információt az AKS Kubernetes támogatási szabályzatában talál.

Ha kérdezni szeretne, írjon nekünk.

 

 

  • Azure Kubernetes Service (AKS)
  • Open Source
  • Retirements