從 App Service 中淘汰 PHP 5.5 執行階段

發佈日期: 十月 11, 2017

由於 PHP Group 已表明不再支援 PHP 5.5,因此該版本不會再有任何更新,包括安全性修正。為了避免 Azure App Service 可能發生安全性問題,我們預計在 2018 年 1 月淘汰支援 PHP 5.5。目前,我們支援 PHP 5.6、7.0 和 7.1。

這項淘汰會影響在 PHP 5.5 執行階段上執行 Web 應用程式的所有客戶 (除非您使用自訂 PHP 執行階段)。因為您的 Web 應用程式將會自動移到 PHP 5.6,所以強烈建議您升級為支援的 PHP 版本。如需如何從 PHP 5.5 移轉至其他 PHP 版本的詳細資訊,請參閱 PHP.net 附錄網頁上的文件。 

雖然我們即將從平台中移除 PHP 5.5 執行階段,但我們知道有些應用程式比較複雜,可能會綁定特定的 PHP 執行階段版本。 為繼續支援 PHP 5.5 應用程式,您仍可繼續使用 PHP 5.5 執行階段。如需詳細資訊,請參閱在 Azure App Service Web Apps 中設定 PHP (機器翻譯) 文件網頁的<如何:使用自訂 PHP 執行階段>(機器翻譯) 一節。 

  • App Service
  • Features
  • SDK and Tools

相關產品