略過導覽
現已提供

Azure HDInsight 上的 Apache Spark 2.4 與 Apache Kafka 2.1 支援

發佈日期: 七月 08, 2019

Azure HDInsight 現在支援 Apache Spark 2.4 與 Apache Kafka 2.1。在 Azure 入口網站中建立叢集時,您可以選擇想要的 Spark 或 Kafka 版本。這兩項更新均帶來了許多新功能、數百項更新和改善。

Spark 2.4 實現了在筆記本中對 Dataframes 的積極評估;支援 Barrier 執行模式來實現與深度學習架構的更佳整合;可讓您使用現有批次連接器的彈性串流接收器;升級的 Kafka 用戶端 (0.10 至 2.0);內建 Higher 順序函式;Apache Avro 資料來源。如需更新的完整清單,請參考 Apache Spark 2.4 的版本資訊。

客戶只要在 HDInsight 上從先前的版本 (1.1) 切換至 Kafka 2.1,就能享有改善的複寫通訊協定;KafkaAdminClient api 的新功能;可設定的配額管理和 Zstandard 壓縮支援,進而獲得更好的訊息代理程式備援。如需更新的完整清單,請參考 Kafka 2.0Kafka 2.1 的版本資訊。

若要開始使用 Azure HDInsight,請參閱我們的文件。您可於 @AzureHDInsight 或 HDInsight 部落格追蹤我們,來獲得第一手消息。如有問題或意見反應,敬請透過 AskHDInsight@microsoft.com 與我們連絡。

  • HDInsight
  • Features

相關產品