在应用服务中停用 PHP 5.5 运行时

发布日期:十月 11, 2017

由于 PHP 开发组指出 PHP 5.5 不再受支持,因此不再有任何对该版本的更新,包括安全修补。为避免 Azure 应用服务中可能出现安全问题,我们已于 2018 年 1 月停用对 PHP 5.5 的支持。我们当前支持 PHP 5.6、7.0 和 7.1。

该项停用将影响在 PHP 5.5 运行时上运行 Web 应用的所有客户(除非你正在使用自定义 PHP 运行时)。强烈建议你升级到受支持的 PHP 版本,因为你的 Web 应用将自动移至 PHP 5.6。要详细了解如何从 PHP 5.5 迁移到另一版本的 PHP,请参阅 PHP.net 的附录网页上的相关文档。 

虽然我们已从平台中删除 PHP 5.5 运行时,但我们注意到有些应用程序很复杂,可能会绑定到特定 PHP 运行时版本。 为继续支持你的 PHP 5.5 应用程序,可能仍采用 PHP 5.5 运行时。有关详细信息,请参阅在 Azure 应用服务 Web 应用中配置 PHP 文档网页的“如何:使用自定义 PHP 运行时”部分。 

  • App Service
  • Features
  • SDK and Tools

相关产品