Azure Kubernetes Service – Trekker tilbake støtte for Kubernetesversjoner 1.11 og 1.12

Publiseringsdato: 30 september, 2019

Mandag 9. desember 2019 (12.09.2019) fjerner vi støtten for versjoner av Kubernetes som er eldre enn den nyeste versjonen (N) og to tidligere, underordnede versjoner (N-2), fordi støtte for Kubernetes 1.15 blir tilgjengelig på denne datoen. Kunder som kjører versjoner av Kubernetes som er eldre enn 1.13.x må oppgradere innen mandag 9. desember 2019 for å fremdeles kunne få støtte. Etter den datoen vil kundene bli bedt om å oppgradere til en versjon som støttes, når de åpner nye støtteforespørsler for Azure. Merk at denne datoen gjelder kun Azure Kubernetes Service og er ikke forbundet med oppstrøms- eller fellesskapsdatoer for Kubernetes 1.15.

Vi foretar denne endringen nå for å bli mer samkjørt med oppstrømsprosjekter i Kubernetes, og for å kunne gi en bedre brukeropplevelse for kundene med tanke på feilretting, sikkerhetsoppdateringer og komponentkompatibilitet.

Etter denne endringen støtter Azure Kubernetes Service den gjeldende generelt tilgjengelige Kubernetes-utgaven og de to tidligere, underordnede versjonene (N-2). Historisk sett har Azure Kubernetes Service støttet både gjeldende generelt tilgjengelig utgave av Kubernetes og de tre tidligere, underordnede versjonene (N-3). Når en ny underordnet versjon er sluppet på markedet, blir den eldste underordnede versjonen fjernet.

Etter mandag 9. desember 2019 vil følgende underordnede versjoner i Kubernetes være støttet:

  • 1.13.x
  • 1.14.x
  • 1.15.x

Her kan du se hvilke versjoner som er tilgjengelig i ditt område:

```
az aks get-upgrades --resource-group myResourceGroup --name myAKSCluster --output table
```

Her kan du se hvordan du oppgraderer klynger ved å bruke kommandolinjegrensesnittet i Azure:

```
az aks upgrade --resource-group myResourceGroup --name myAKSCluster --kubernetes-version <NEW VERSION>
```

Du finner ytterligere informasjon iAzure Kubernetes Service sin støttepolicy for Kubernetes.

Hvis du har spørsmål, kan du ta kontakt med oss.

 

 

Mandag 9. desember 2019 (12.09.2019) fjerner vi støtten for versjoner av Kubernetes som er eldre enn den nyeste versjonen (N) og to tidligere, underordnede versjoner (N-2), fordi støtte for Kubernetes 1.15 blir tilgjengelig på denne datoen. Kunder som kjører versjoner av Kubernetes som er eldre enn 1.13.x må oppgradere innen mandag 9. desember 2019 for å fremdeles kunne få støtte. Etter den datoen vil kundene bli bedt om å oppgradere til en versjon som støttes, når de åpner nye støtteforespørsler for Azure. Merk at denne datoen gjelder kun Azure Kubernetes Service og er ikke forbundet med oppstrøms- eller fellesskapsdatoer for Kubernetes 1.15.

Vi foretar denne endringen nå for å bli mer samkjørt med oppstrømsprosjekter i Kubernetes, og for å kunne gi en bedre brukeropplevelse for kundene med tanke på feilretting, sikkerhetsoppdateringer og komponentkompatibilitet.

Etter denne endringen støtter Azure Kubernetes Service den gjeldende generelt tilgjengelige Kubernetes-utgaven og de to tidligere, underordnede versjonene (N-2). Historisk sett har Azure Kubernetes Service støttet både gjeldende generelt tilgjengelig utgave av Kubernetes og de tre tidligere, underordnede versjonene (N-3). Når en ny underordnet versjon er sluppet på markedet, blir den eldste underordnede versjonen fjernet.

Etter mandag 9. desember 2019 vil følgende underordnede versjoner i Kubernetes være støttet:

  • 1.13.x
  • 1.14.x
  • 1.15.x

Her kan du se hvilke versjoner som er tilgjengelig i ditt område:

```
az aks get-upgrades --resource-group myResourceGroup --name myAKSCluster --output table
```

Her kan du se hvordan du oppgraderer klynger ved å bruke kommandolinjegrensesnittet i Azure:

```
az aks upgrade --resource-group myResourceGroup --name myAKSCluster --kubernetes-version <NEW VERSION>
```

Du finner ytterligere informasjon iAzure Kubernetes Service sin støttepolicy for Kubernetes.

Hvis du har spørsmål, kan du ta kontakt med oss.

 

 

  • Azure Kubernetes Service (AKS)
  • Open Source
  • Retirements