Hopp over navigasjon

Sikkerhetsoppdatering av Azure IoT Edge Moby-motor for CVE-2020-13401

Publiseringsdato: 02 juni, 2020

Det er identifisert et sikkerhetsproblem i Moby motorkomponenter i Azure IoT Edge. (Windows-versjoner påvirkes ikke.) Hent detaljer for denne feilen: CVE-2020-13401.

Utfør disse trinnene for å løse problemet i Moby-motorversjon 3.0.12 eller nyere:

  1. Stopp iotedge-daemon.
    • sudo systemctl stop iotedge
       
  2. Fjern den eksisterende moby-engine-pakken.
    • sudo apt-get fjern docker
       
  3. Slett lagret moby-engine-kontekst. Dette fjerner alle hurtigbufrede beholdere.
    • ​​sudo rm -rf /var/lib/docker
       
  4. Følg instruksjonene for å installere moby-engine, og verifiser at versjonen 3.0.12 eller senere etter installasjon.
    •  sudo docker-versjon
       
  5.  Start iotedge-daemon.
    •  sudo systemctl start iotedge

Last ned RPM-pakken.

  • Azure IoT Edge
  • Compliance
  • Security

Relaterte produkter