KULLANIMA SUNULDU

Azure Kubernetes Service’te desteklenen Kubernetes düzeltme eki sürümlerini azaltma

Yayımlanma tarihi: 24 Eylül, 2018

Bu haftadan itibaren Azure Kubernetes Service (AKS), kullanılabilen her ikincil sürüm için yalnızca iki kararlı düzeltme eki sürümünü desteklemeye başlayacaktır.

AKS önceden şu beş Kubernetes ikincil sürümü desteklerdi: 1.7, 1.8, 1.9, 1.10 ve 1.11. Desteği ikincil sürüm başına iki düzeltme eki düzeyine azaltmak, birden fazla düzeltme eki sürümü arasında seçim yapma gereksinimine ilişkin karmaşıklığı ortadan kaldırır. Artık desteklenmeyen bir düzeltme eki sürümünü kullanıyorsanız kullanımınız bu değişiklikten hiçbir şekilde etkilenmeyecektir. Bu düzeltme eki sürümünde kalmayı veya söz konusu ikincil sürümde ya da sonraki ikincil sürümde desteklenen iki düzeltme eki sürümünden birine yükseltmeyi tercih edebilirsiniz. 

Düzeltme eki sürümleri Kubernetes’e dayalı olarak üretimde çalışan çok sayıda müşteriyi ve ürünü etkileyen önemli hataların yanı sıra ikincil sürümlerdeki kritik hataları (güvenlik açıkları da dahil) düzeltmeye yöneliktir. Bunlar yeni özellik tümleştirmeleri içermez. İkincil bir sürümün düzeltme eki sürümleri arasında hiçbir zaman uyumsuzluk yoktur. Bu değişiklik şu anda tüm genel bölgelerde kullanıma sunulmaya başlandı ve haftanın sonuna kadar tamamlanması bekleniyor. 

  • Azure Kubernetes Service (AKS)
  • Features
  • Services
  • Open Source