Gezintiyi Atla

Azure Bot Hizmeti’nde aktarım katmanı güvenliği (TLS) 1.2 zorunlu oluyor

Yayımlanma tarihi: 14 Kasım, 2018

Azure Bot Hizmeti, 4 Aralık 2018’den itibaren tüm bağlantıların aktarım katmanı güvenliği (TLS) 1.2 güvenli hale getirilmiş olmasını gerektirecek.

Bu gereksinim, verileriniz için mümkün olan en iyi güvenliğin sağlanması açısından kritik öneme sahiptir. Microsoft, Payment Card Industry (PCI) İnternet topluluğunun tamamı, başarılı olmaya kararlı saldırganlara karşı zayıf olabileceği kanıtlanmış olan TLS 1.0 ve TLS 1.1 sürümlerini terk ediyor.

Bu değişiklik, bir sohbet istemcisinden ya da bottan Azure Bot Hizmeti sunucularına yönelik tüm bağlantılar için bağlayıcı olacaktır. Şimdilik Azure Bot Hizmeti’nden botlara yönelik bağlantılar için zorunlu olmayacaktır.

 

Daha Fazla Bilgi

Azure Bot Hizmeti’ne yönelik bağlantıların büyük çoğunluğu zaten TLS 1.2 kullanıyor. Geriye kalan azınlık, eski istemcilerden veya eski işletim sistemlerinden bağlanıyor. Çoğu durumda, TLS 1.2’nin etkinleştirilmesi için tek gereken daha yeni bir tarayıcıya yükseltmek ya da işletim sistemine düzeltme eki uygulamaktır.

Botların eski protokolleri kabul etmesine izin vermeye devam edecek olsak da bu özelliği yakında kullanımdan kaldıracağımız için bot geliştiricilerinin sunucularını TLS 1.2 veya üzerini kabul edecek şekilde yapılandırması önerilir. Botunuz Azure Web Apps veya İşlevler üzerinde barındırılıyorsa bu değişikliği yapmak kolaydır. Botunuz Windows Server 2008 veya Windows 7 (Windows Server 2008 R2) gibi eski bir Windows sürümünde çalışıyorsa bir düzeltme ekini yüklemeniz ve güncelleştirilen protokolleri etkinleştirmeniz gerekir. Windows Vista ve önceki sürümlerde TLS 1.2 desteklenmez.

Aşağıdaki istemcilerin TLS 1.2 kullanamadığı bilinmektedir. İstemcilerinizi güncelleştirin ve hizmete kesintisiz olarak erişmeye devam edebilmeleri için müşterilerinizi de aynısını yapmaya davet edin.

  • Android 4.3 ve önceki sürümler
  • Firefox sürüm 5.0 ve önceki sürümler
  • Windows 7 ve önceki sürümlerde Internet Explorer 8-10
  • Win Phone 8.0 sürümünde Internet Explorer 10
  • Safari 6.0.4/OS X10.8.4 ve önceki sürümler

Daha fazla bilgi edinin

  • Compliance
  • Services