NOW AVAILABLE

Minimal TLS version setting is now available for Azure Database for PostgreSQL

Published date: 04 June, 2020

Enforce a minimal TLS version at the server level that applies to Azure Database for PostgreSQL using the new TLS version setting.

We currently support TLS versions 1.0, 1.1, and 1.2. Setting a minimal TLS version ensures that subsequent, newer TLS versions are supported. We recommend setting the minimal TLS version to 1.2, after testing to confirm your applications support it, because it includes fixes for vulnerabilities found in previous versions. It’s also the highest TLS version supported in Azure Database for PostgreSQL.

If you have applications that rely on older versions of TLS, we recommend setting the minimal TLS version per the requirements of your applications. If you rely on applications to connect using an unencrypted connection, we recommend not setting any minimal TLS version.

Read more information about minimum TLS versions.

Learn more about TLS 1.2.

  • Azure Database for PostgreSQL
  • Compliance
  • Features
  • Open Source
  • Security