Azure IoT Edge version 1.0.2

Udgivet den 26. september 2018

Opdatering 1.0.2 til Azure IoT Edge indeholder følgende forbedringer:

  • En offentlig prøveversion af den udvidede offline-funktion lader en Edge-enhed og downstream-enheder forbundet til den arbejde offline på ubestemt tid. Du finder flere oplysninger i blogindlægget, som fortalte om funktionen.
  • Edge-enheder kan nu arbejde via en proxy-server. Der er tilføjet produktdokumentation, som forklarer konfigurationen af denne funktion.
  • Der er fjernet forskellige fejl i både Edge Hub og Edge Agent. (du finder en komplet liste med ændringer i produktbemærkningerne på GitHub.) Vi har især forbedret opstartstiden og løst et problem, som medførte, at en edge-enhed anvendte en uventet båndbredde.

Du skal opdatere alle runtime-komponenter til version 1.0.2 for at få fordelene fra denne udgivelse. Dette gør du ved hjælp af den følgende vejledning.

 

Opdater Security Daemon (Linux)

Trin 1: Få den nyeste version af pakkerne ved at køre følgende kommando på edge-enheden:

apt-get upgrade

Trin 2: Installer den nyeste version af hsmlib og Security Daemon ved at køre følgende kommando på edge-enheden:

apt-get install libiothsm iotedge

 

Opdater Security Daemon (Windows)

Trin 1: Afinstaller den gamle version af Security Daemon ved at køre følgende kommando på edge-enheden:

. {Invoke-WebRequest -useb aka.ms/iotedge-win} | Invoke-Expression; `

UnInstall-SecurityDaemon

Trin 2: Installer den nye version af Security Daemon afhængigt af, om du bruger Windows-objektbeholdere eller Linux-objektbeholdere.

 

Opdater Edge Hub og Edge Agent (både Linux og Windows)

Slet eksisterende modulafbildninger med "docker rmi" (udført på edge-enheden), hvis din aktuelle installation bruger 1.0-afbildninger. 1.0-afbildninger er rullende koder, som henviser til den seneste 1.0.x-afbildning. Når runtime henter "1.0"-afbildningen, hentes den nyeste 1.0-afbildning, som nu er 1.0.2.

 

Du kan også opdatere installationsskemaet for edgeHub- og edgeAgent-afbildningsversionen til 1.0.2.