FÅS NU

Azure Kubernetes Service – udfasning af understøttelse af Kubernetes-versionerne 1.11 og 1.12

Opdateret: 30 september, 2019

Mandag den 9. december 2019 (09-12-2019) ophører understøttelsen af Kubernetes-versioner, der er ældre end den nyeste version (N) samt to mindre tidligere versioner (N-2), da Kubernetes 1.15 understøttes fra denne dato. Kunder, der kører Kubernetes-versioner, der er ældre end Kubernetes 1.13.x, skal opgradere inden mandag den 9. december 2019 for fortsat at anvende en understøttet version. Efter denne dato bliver kunderne bedt om at opgradere til en understøttet version, når de åbner nye Azure-supportanmodninger. Bemærk! Denne dato er specifik for AKS og er ikke relateret til eventuelle upstream- eller communitydatoer for Kubernetes 1.15.

Vi foretager denne ændring nu for at sikre en tættere afstemning med upstream-Kubernetes-projektet og for at give kunderne en mere konsekvent oplevelse i forhold til fejlrettelser, sikkerhedsrettelser og komponentkompatibilitet.

Med denne ændring understøtter AKS den Kubernetes-version, der i øjeblikket er generelt tilgængelig, samt de to tidligere mindre versioner (N-2). Historisk set har AKS understøttet den version af Kubernetes, der i øjeblikket er tilgængelig, samt de tre tidligere mindre versioner (N-3). Når der udgives en ny mindre version, fjernes den ældste mindre version.

Efter mandag den 9. december 2019 understøttes følgende mindre Kubernetes-versioner:

  • 1.13.x
  • 1.14.x
  • 1.15.x

Hvis du vil kontrollere, hvilke versioner der er tilgængelige i dit område:

```
az aks get-upgrades --resource-group myResourceGroup --name myAKSCluster --output table
```

Hvis du vil opgradere dine klynger vha. kommandolinjegrænsefladen på Azure:

```
az aks upgrade --resource-group myResourceGroup --name myAKSCluster --kubernetes-version <NEW VERSION>
```

Du kan få flere oplysninger på Politik om AKS Kubernetes-understøttelse.

Kontakt os, hvis du har spørgsmål.

 

 

Mandag den 9. december 2019 (09-12-2019) ophører understøttelsen af Kubernetes-versioner, der er ældre end den nyeste version (N) samt to mindre tidligere versioner (N-2), da Kubernetes 1.15 understøttes fra denne dato. Kunder, der kører Kubernetes-versioner, der er ældre end Kubernetes 1.13.x, skal opgradere inden mandag den 9. december 2019 for fortsat at anvende en understøttet version. Efter denne dato bliver kunderne bedt om at opgradere til en understøttet version, når de åbner nye Azure-supportanmodninger. Bemærk! Denne dato er specifik for AKS og er ikke relateret til eventuelle upstream- eller communitydatoer for Kubernetes 1.15.

Vi foretager denne ændring nu for at sikre en tættere afstemning med upstream-Kubernetes-projektet og for at give kunderne en mere konsekvent oplevelse i forhold til fejlrettelser, sikkerhedsrettelser og komponentkompatibilitet.

Med denne ændring understøtter AKS den Kubernetes-version, der i øjeblikket er generelt tilgængelig, samt de to tidligere mindre versioner (N-2). Historisk set har AKS understøttet den version af Kubernetes, der i øjeblikket er tilgængelig, samt de tre tidligere mindre versioner (N-3). Når der udgives en ny mindre version, fjernes den ældste mindre version.

Efter mandag den 9. december 2019 understøttes følgende mindre Kubernetes-versioner:

  • 1.13.x
  • 1.14.x
  • 1.15.x

Hvis du vil kontrollere, hvilke versioner der er tilgængelige i dit område:

```
az aks get-upgrades --resource-group myResourceGroup --name myAKSCluster --output table
```

Hvis du vil opgradere dine klynger vha. kommandolinjegrænsefladen på Azure:

```
az aks upgrade --resource-group myResourceGroup --name myAKSCluster --kubernetes-version <NEW VERSION>
```

Du kan få flere oplysninger på Politik om AKS Kubernetes-understøttelse.

Kontakt os, hvis du har spørgsmål.

 

 

  • Azure Kubernetes Service (AKS)
  • Open Source
  • Retirements