Skip Navigation
NOW AVAILABLE

Generally Available: AKS support for API breaking change detection

Published date: 06 December, 2023

Azure Kubernetes Service (AKS) now supports fail fast on minor version change of Kubernetes cluster upgrades. This feature alerts you with an error message if it detects usage of deprecated Kubernetes standard APIs in the intended goal version provided you are using the latest API version. Detecting the change at this stage saves you from having to spend time on post upgrade workload troubleshooting. 

The deprecated APIs are as per the Kubernetes Deprecated API Migration Guide: https://kubernetes.io/docs/reference/using-api/deprecation-guide/

Learn more.

 

  • Azure Kubernetes Service (AKS)
  • Features