Пропустить навигацию
УЖЕ ДОСТУПНО

Update PowerShell versions 7.0 and 7.1 to protect against a remote code execution vulnerability

Дата публикации: 01 июля, 2021

If you manage your Azure resources from PowerShell version 7.0 or 7.1, we’ve released new versions of PowerShell to address a .NET Core remote code execution vulnerability in versions 7.0 and 7.1.
We recommend that you install the updated versions as soon as possible.

Windows PowerShell 5.1 isn’t affected by this issue.

Required action

To best protect against this vulnerability, please install the new PowerShell version as soon as possible to update from:
•    Version 7.0 to 7.0.6 
•    Version 7.1 to 7.1.3

Help and support

If you have questions, ask them in GitHub, where the Microsoft development team and the community of experts are closely monitoring for new issues and will provide answers as soon as possible.

If you have a support plan and you need technical help, please create a support request.

  • Management
  • SDK and Tools
  • Security