УЖЕ ДОСТУПНО

Прекращение поддержки устаревших версий REST API службы управления API Azure

Дата публикации: 19 октября, 2018

Ниже перечислены версии REST API службы управления API Azure, которые отмечаются как нерекомендуемые и поддержка которых будет прекращена 1 октября 2019 г.: 

– 2014-02-14-preview;
– 2014-02-14;
– 2015-09-15;
– 2016-07-07;
– 2016-10-10;
– 2017-03-01.

Это повлияет на следующие клиентские библиотеки, которые зависят от устаревших API:

– пакеты SDK NuGet для .NET для Microsoft.Azure.Management.ApiManagement до версии 4.0.0-preview;
– модули командлетов PowerShell для AzureRm.ApiManagement до версии 6.1.0.

Все существующие клиентские библиотеки Java, Node и Go не будут затронуты.

Клиентам, которые используют любые устаревшие версии API, библиотек или пользовательских средств и интеграций (и строят работу на их основе), следует выполнить обновление до более поздних версий до 1 октября 2019 г., чтобы избежать перебоев в работе служб.

  • Управление API
  • Features
  • Management
  • SDK and Tools

Связанные продукты