TLS 1.2 recommandé pour les applications Power BI Embedded

Date de publication : 10 avril, 2019

Dans le cadre des programmes Microsoft visant à garantir aux clients le contrôle de la sécurité des communications avec les services Microsoft, nous vous recommandons vivement (et exigerons à l’avenir) que vous mettiez à niveau la version TLS de votre application vers TLS 1.2. 

Qu’est-ce que TLS ?

TLS est l’acronyme de « Transport Layer Security », protocole standard conçu pour protéger la confidentialité des informations communiquées sur Internet. TLS est utilisé dans de nombreux navigateurs web et applications communiquant via HTTPS et TCP.

Si vous utilisez une application .NET, effectuez l’une des opérations suivantes :

  • Si votre application s’exécute sur .NET Framework 4.6 ou supérieur, à moins d’être modifiée, la configuration par défaut continuera à fonctionner.
  • Si votre application s’exécute sur une version de .NET Framework antérieure à la version 4.6, vous pouvez activer le protocole par programme lorsque votre application commence à s’exécuter à l’aide de la ligne de code suivante :

System.Net.ServicePointManager  .SecurityProtocol |= SecurityProtocolType.Tls11 | SecurityProtocolType.Tls12;

Le SDK d’API Power BI prend en charge .NET Standard 2.0 à partir de la version 2.1.0, ce qui ajoute une prise en charge dans TLS version 1.2. Vous pouvez télécharger la dernière version du SDK ici.

Pour Powershell - Ajoutez [System.Net.ServicePointManager]::SecurityProtocol = [System.Net.SecurityProtocolType]::Tls12 à votre script Powershell

Pour les logiciels non-.NET, veuillez consulter votre fournisseur. Pour la plupart des langages, il suffit d’une simple entrée de configuration.

Des informations supplémentaires sont disponibles dans la documentation Microsoft sur TLS 1.2.

  • Power BI Embedded
  • Security

Produits apparentés