Mise à jour de sécurité pour le moteur Azure IoT Edge Moby pour CVE-2020-13401

Date de publication : 02 juin, 2020

Une faille de sécurité a été identifiée dans les composants du moteur Moby dans Azure IoT Edge. (Les versions de Windows ne sont pas affectées.) Obtenez des informations pour ce problème : CVE-2020-13401.

Procédez comme suit pour résoudre le problème dans la version 3.0.12 ou ultérieure du moteur Moby :

  1. Arrêtez le démon iotedge.
    • sudo systemctl stop iotedge
       
  2. Supprimez le package moby-engine existant.
    • sudo apt-get remove docker
       
  3. Supprimez le contenu moby-engine enregistré. Cette opération supprime tous les conteneurs mis en cache.
    • ​​sudo rm -rf /var/lib/docker
       
  4. Suivez les instructions pour installer moby-engine, et vérifiez qu’il s’agit de la version 3.0.12 ou ultérieure après l’installation.
    •  Version de sudo docker
       
  5.  Démarrez le démon iotedge.
    •  sudo systemctl start iotedge

Téléchargez le package RPM.

  • Azure IoT Edge
  • Compliance
  • Security

Produits apparentés