Omitir navegación

Se recomienda TLS 1.2 para las aplicaciones de Power BI Embedded

Fecha de publicación: 10 abril, 2019

Dentro del marco de los programas de Microsoft para asegurar que los clientes tengan el control de la seguridad de las comunicaciones con los servicios de Microsoft, se recomienda encarecidamente (y se requerirá en el futuro) actualizar la versión de TLS de las aplicaciones a TLS 1.2. 

¿Qué es TLS?

TLS es la sigla del inglés “Transport Layer Security” (Seguridad de la capa de transporte) y es un protocolo estándar del sector diseñado para proteger la privacidad de la información comunicada a través de Internet. TLS se utiliza en muchos exploradores y aplicaciones web que se comunican a través de HTTPS y TCP.

Si utiliza una aplicación basada en .NET, realice una de las dos acciones siguientes:

  • Si la aplicación se ejecuta en .NET Framework 4.6 o posterior, seguirá funcionando, a menos que haya modificado la configuración predeterminada.
  • Si la aplicación se ejecuta en una versión de .NET Framework anterior a la 4.6, puede habilitar el protocolo mediante programación cuando se empiece a ejecutar la aplicación con la siguiente línea de código:

System.Net.ServicePointManager  .SecurityProtocol |= SecurityProtocolType.Tls11 | SecurityProtocolType.Tls12;

El SDK de la API de Power BI admite .NET Standard 2.0 desde la versión 2.1.0, que agrega compatibilidad con TLS 1.2. Puede descargar la última versión del SDK aquí.

Para Powershell, agregue [System.Net.ServicePointManager]::SecurityProtocol = [System.Net.SecurityProtocolType]::Tls12 al script de Powershell

Para el software que no se base en .NET, consulte a su proveedor. En la mayoría de los lenguajes, se puede hacer con una sencilla entrada de configuración.

Encontrará más información en la página "TLS 1.2 support at Microsoft" (Compatibilidad con TLS 1.2 en Microsoft).

  • Power BI Embedded
  • Security

Productos relacionados