Omitir navegación
EN VERSIÓN PRELIMINAR

Azure Bot Service exige Seguridad de la capa de transporte (TLS) 1.2

Fecha de publicación: 14 noviembre, 2018

A partir del 4 de diciembre de 2018, será obligatorio que todas las conexiones de Azure Bot Service estén protegidas con Seguridad de la capa de transporte (TLS) 1.2.

Esta exigencia es crucial para ofrecer la mayor seguridad posible para sus datos. Microsoft, la industria de tarjetas de pago (PCI) y toda la comunidad de Internet están dejando de usar TLS 1.0 y TLS 1.1 porque se ha detectado que son vulnerables a determinados ataques.

Este cambio se va a exigir para todas las conexiones a servidores de Azure Bot Service, ya sean desde un cliente de chat o desde un bot. Aún no se exigirá para las conexiones de Azure Bot Service a bots.

 

Más información

La inmensa mayoría de conexiones con el servicio Azure Bot Service ya utilizan TLS 1.2. Las pocas que no lo utilizan corresponden a clientes o sistemas operativos antiguos. En la mayoría de los casos, solo es necesaria una actualización a una versión más reciente del explorador o una revisión del sistema operativo para habilitar TLS 1.2.

Aún se permitirá que los bots acepten los protocolos anteriores, pero dejarán de usarse en el futuro, por lo que se recomienda que los desarrolladores de bots configuren sus servidores para aceptar TLS 1.2 o posterior. Si su bot está hospedado en Azure Web Apps o Functions, el cambio es sencillo. Si su bot está hospedado en una versión anterior de Windows, como Windows Server 2008 o Windows 7 (Windows Server 2008 R2), deberá instalar una revisión y habilitar los protocolos actualizados. TLS 1.2 no se admite en Windows Vista o versiones anteriores.

Se sabe que los clientes siguientes no pueden utilizar TLS 1.2. Actualice sus aplicaciones cliente y anime a sus clientes a hacer lo mismo para asegurar un acceso sin interrupciones al servicio.

  • Android 4.3 y versiones anteriores
  • Firefox 5.0 y versiones anteriores
  • Internet Explorer 8-10 en Windows 7 y versiones anteriores
  • Internet Explorer 10 en Windows Phone 8.0
  • Safari 6.0.4/OS X10.8.4 y versiones anteriores

Más información

  • Compliance
  • Services